Enlaces
Esta en:

documentos
Arriba
Bind-9
Bind-8
Ad+bind
Dhcp
Kdephp
Shell
Trucos
Php
Documentos
Cuestiones php
Fedora
Legal
W2000 xp
COMOS
Errores dns

Re: [PHP-ES] Re: problema con paso de URL, para intranet funciona más no para subdominio

Write haof XML files: Diego Firmenich <diego.firmenich_at_gmail.com>
Fecha: Tue, 17 Apr 2007 20:53:28 -0300

Hola Mario.
La forma correcta de hacer lo que quieres es configurar un reverse proxy en
tu Servidor A utilizando la directiva ProxyPass/ProxyPassReverse de la
extensión mod_proxy.
Documentación: http://httpd.apache.org/docs/2.0/mod/mod_proxy.html#proxypass

Saludos.
Diego Andrés Firmenich

On 4/17/07, Carlos Medina <medina12_at_web. de> wrote:
>
> Cesar A. wrote:
> > Saludos.
> >
> > Trataré de describir mi problema, por favor, sí consideran que he
> omitido algún detalle, con gusto lo daré.
> >
> > Un servidor A, para el portal institucional + bind9 + apache2 + DNS
> > Un servidor B, para los diferentes sistemas administrativos. Apache2
> .... más nada!
> >
> > Por un requerimiento, se ha solicitado que algunos de los sistemas que
> están en B, puedan ser accesados desde internet por la vía de subdominios de
> la forma sistema.portal.tal
> >
> > Actualmente, a los sistemas, desde la intranet, se ingresa
> http://direcionip/sistema
> >
> > En uno de las aplicaciones existe un sistema de autenticación de la
> forma:
> >
> > archivos.php
> > <?php
> > session_start();
> > include_once('./include/aut_verifica.inc.php');
> > $perm = true;
> > if ($_SESSION['usuario_nivel'] == $visitante) {
> > $perm = false;
> > }
> > ?>
> >
> > donde, aut_verifica.inc.php tiene algunas variantes del original, de la
> forma:
> > <?php
> > $url = explode("?",$_SERVER['REQUEST_URI']);
> > $pag_referida=$url[0];
> > $redir = $pag_referida;
> > if ($_SERVER['REQUEST_URI'] == ""){
> > die ("Error cod.:1 - Acceso incorrecto!");
> > exit;
> > }
> > // y sigue la validación contra la BD...
> > ?>
> >
> > El problema:
> >
> > index.php es la portada, donde tiene un enlace a login.php que es el
> form de logeo, de pasar, el form apunta a index2.php
> >
> > Desde la intranet, funciona perfectamente, pero al tratar de accesar
> desde subdominio, arroja el error de que no encuentra index2.php,
> repitiendo el directorio padre de index2.php, así ->
> >
> > Not Found
> > The requested URL /sistema/sistema/index2.php was not found on this
> server.
> >
> > Cuando, no debería repetirlo...
> >
> > Necesito pistas a seguir... cualquier idea será siempre bienvenida
> >
> > Cesar A. Carbonara R.
> > Usuario Linux 377997
> > Debian
> > www.gulmer.org.ve
> >
> >
> >
> >
> >
> >
> ____________________________________________________________________________________
> > LLama Gratis a cualquier PC del Mundo.
> > Llamadas a fijos y móviles desde 1 céntimo por minuto.
> > http://es.voice.yahoo.com
> Hola Mario,
> mala configuracion en el Apache, o mal codeo con el .htaccess o algun
> Script de PHP con redireccion a index2.php
>
>
> Saludos
>
> Carlos
>
> --
> PHP Spanish Localization Talk Mailing List (http://www.php.net/)
> To unsubscribe, visit: http://www.php.net/unsub.php
>
>
Nearby mié abr 18 2007 - 06:23:06 CEST

Este archivo fue generado por hypermail 2.2.0 : mié nov 07 2007 - 20:55:36 CET


Página Principal
Google

Web
dns.bdat.net

Visita nuestro proveedor:
www.bdat.net

Publicidad:

Impresenteibols:Humor Jazz, música en vivo