Google
Web dns.bdat.net

RE: [PHP-ES] Instalar php4 o php5 en explotación

Write haof XML files: Hari Seldon ( hari.seldon@telefonica.net)
Fecha: jue 15 sep 2005 - 11:29:46 CEST


        PHP 5 ya está en stable; lo que no está es aún demasiado implantado;
pero está en stable, y va muy bien. Y temas como XML, SOAP, y alguna cosita
más, va _bastante_ mejor que en PHP 4 que había que montar unas historias...

        En Debian, PHP 5 lo tienes en SID, como poco; yo lo tengo montado en
SID con los repositorios oficiales de SID, y después he utilizado
posteriormente los repositorios de dotdeb porque tienen alguna extensión,
como MING, que no tienen los oficiales (aunque curiosamente MING parece que
no viene activada, o bien no la monta bien....)

Es más, ahí va la copia de mi sources.list (tengo metidos dos repositorios
de unstable de debian por si las moscas):

 # OFICIALES DEBIAN
 # SID: (ya hay en SID php5)
deb http://http.us.debian.org/debian unstable main contrib
deb-src http://http.us.debian.org/debian unstable main contrib

deb http://ftp.es.debian.org/debian/ unstable main
deb-src http://ftp.es.debian.org/debian unstable main

 # OLD STABLE:
#deb http://http.us.debian.org/debian oldstable main contrib
 # PHP 5 FROM DOTDEB
deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all

        El problema lo puedes tener con ciertas aplicaciones que no sean
compatible con PHP 5, por mucho que utilizes el Zend Engine Compatibility
del php.ini:

zend.ze1_compatibility_mode = On

        Pero con esto podrás solucionar bastantes cosas.

        Si es un servidor de producción con unos pocos vhosts, debería de
bastarte con esta información.

        Tienes también en el historial de la lista comentarios acerca de
todo esto (en concreto, yo he lanzado varios threads sobre si es posible
montar en linux php 4 y php 5, cosa que aún no he tenido tiempo a montar,
pero que creo que montando php 4 vía apt, y compilando php 5 en directorios
diferentes a los de php 4, podría funcionar)

        Un saludo.

> -----Mensaje original-----
> De: Pablo Gotor [mailto: pgotor2004@yahoo.es]
> Enviado el: jueves, 15 de septiembre de 2005 9:53
> Para: php-es@lists.php.net
> Asunto: [PHP-ES] Instalar php4 o php5 en explotación
>
> Hola, me han pedido montar en mi empresa un sistema de desarrollo y
> explotación en php, mysql sobre apache en un debian sarge.
> Mi duda es qué versión de php (4 o 5) debo instalar.
> Por lo que he podido ver sólo la 4 está en stable y la 5 no
> está ni en
> testing.
> Vosotros que me recomendáis. Debo instalar php4 y esperar a
> que exista
> versión estable de php5?
> Qué tendencia hay en debian con respecto a ésto?
>
> Muchas gracias por adelantado.
>
> Un saludo,
>
> Pablo
>
> --
> PHP Spanish Localization Talk Mailing List (http://www.php.net/)
> To unsubscribe, visit: http://www.php.net/unsub.php
>

-- 
PHP Spanish Localization Talk Mailing List (http://www.php.net/)
To unsubscribe, visit: http://www.php.net/unsub.php


Este archivo fue generado por hypermail 2.1.7 : sáb 18 mar 2006 - 18:23:49 CET